[ZODB-Dev] "Versions aren't supported" message in Plone 4 upgrade

Jim Fulton jim at zope.com
Thu Sep 9 10:03:56 EDT 2010

On Wed, Sep 8, 2010 at 5:28 PM, Mike Hammill <mike at kth.se> wrote:
> Just wondering if anyone could point me in the right direction.
> I'm getting the error:
> ValueError: Non-zero version length. Versions aren't supported.
> when trying to bring up a Data.fs from Plone 3.3.1 in Plone 4.0.0.  The
> Data.fs file was made by doing a snapshotbackup of a production Plone
> 3.3.1 and then snapshotrestore under Plone 4.0.0.  The full error is at
> <http://pastie.org/1146604>.  #plone folks suggested I ask here.

That's annoying. :)

>  Is
> this a corrupt database?  Do I have to upgrade 3.3.1 to some newer 3.3.x
> before 4.0.0?  Any ideas?

Your database contains versions. Versions haven't been supported in Zope
(and thus Plone) in years as far as I know. ZODB 3.9 no-longer supports
versions. You can't use a database containing versions with ZODB 3.9
(and presumably Plone 4).

Have you tried packing your database?


Jim Fulton

More information about the ZODB-Dev mailing list