[Zope-Coders] Re: [Zope-dev] Speaking of 2.6...
Stephan Richter
srichter@cbu.edu
Tue, 09 Apr 2002 14:49:56 -0500
At 03:43 PM 4/9/2002 -0400, Shane Hathaway wrote:
>Mario Valente wrote:
>> Both me and Myroslav Opyr <myroslav@zope.net.ua> are quite
>> commited to do the proposed "Object Links/References". Although
>> from the emails we exchanged with you, I would've guessed that
>> it was one of the "controversial enough" to be a Vetted item :-)
>> Anyways I'm commited to do it. I do agree with your argument about
>> link semantics but, at least for me, a link/reference is a link, and the
>> semantics are perfectly defined i.e its not a RedirectObject.
>> As in Unix, a hard link has different semantics from a soft link. I'm
>> thinking of the "hard link" semantics.
>
>Object links and references might not be realistic for Zope 2, unless you
>can solve the ID problem. The ID of an object is currently stored in two
>objects--the container and the object. If they do not match, bad things
>will happen. ZMI, getPhysicalPath(), restrictedTraverse(), etc. will get
>confused.
>
>When you make a hard link or symlink, the ID then has to match in several
>places. If you rename a link, does that change the name of the original
>object? It shouldn't, but unless it renames the original object also,
>you're in trouble.
>
>Maybe we could say that objects that are linked must never be renamed. But
>then we'd lose one of the main benefits of links.
>
>I suggest it may be best to wait for Zope 3.
>
>... or even better help integrating a Symlink in Zope 3. :-)
--
Stephan Richter
CBU - Physics and Chemistry Student
Web2k - Web Design/Development & Technical Project Management