[Zope-dev] Defining Interfaces
Jeffrey P Shell
jeffrey@cuemedia.com
Sun, 27 Jan 2002 15:11:37 -0700
On 1/27/02 3:09 PM, "Steve Alexander" <steve@cat-box.net> wrote:
> In which case, perhaps we should change InterfaceInterface and
> InterfaceBaseInterface from Interface/iclass.py to reflect this.
>
> The ZDG should also be updated to reflect this, as the example is wrong.
>
> http://www.zope.org/Documentation/ZDG/ComponentsAndInterfaces.stx
>
> from Interface import Base
>
> class Hello(Base):
> """ The Hello interface provides greetings. """
>
> def hello(self, name):
> """ Say hello to the name """
>
> class HelloComponent:
>
> __implements__ = Hello
>
> def hello(self, name):
> return "hello %s!" % name
>
>
> Shall I throw this into the Collector?
Probably. I made a comment on the page itself, just a couple of days ago,
but it's unknown how often those comments are reviewed:
>> jshell - Jan. 24, 2002 12:56 pm - This should all be updated to reflect where
>> interfaces are going for Zope 3. First, the interface should be named
>> "IHello", and there should be no 'self' in the signature for the 'hello()'
>> method.
--
Jeffrey P Shell
www.cuemedia.com
Sent using the Entourage X Test Drive.