[Zope-dev] a better propertyLabel as standard?

Lennart Regebro lennart@regebro.nu
Thu, 22 May 2003 15:20:11 +0200


What about replacing the default propertyLabel of PropertyManager with 
the one from CMF:

     def propertyLabel(self, id):
         """Return a label for the given property id
         """
         for p in self._properties:
             if p['id'] == id:
                 return p.get('label', id)
         return id

The current one:

     def propertyLabel(self, id):
         """Return a label for the given property id
         """
         return id

Is kinda silly and this little change would make things neater, and 
remove the use of having it a separate function in CMF, where it really 
doesn't belong.

Thoughts?