[Zope] Solution UserCounter: PROBLEM(100)
hans
hans@beehive.de
Mon, 13 May 2002 16:46:12 +0100
eric.n.dunn@bankofamerica.com wrote:
> ---------------------- Forwarded by Eric N. Dunn/USA/BAC on 05/13/2002 10:30
> AM
> Sean Treadway <seant@superchannel.org> on 05/13/2002 10:02:27 AM
> To: Eric N. Dunn/USA/BAC@BankofAmerica
> cc:
> Subject: Re: UserCounter
>
> I believe this is just a warning.
>
> If you wish to get rid of the warning (it dates back to the python 1.5
> days.)
> You can change this line:
> manage = manage_main = HTMLFile('www/UserCounterStats', globals())
> to:
> manage_main = HTMLFile('www/UserCounterStats', globals())
>
> On Monday 13 May 2002 15:19, you wrote:
> > I like your UserCounter and it works great, but I'm getting an error on
> the
> > ZServer startup
> >
> > 2002-05-13T13:03:50 PROBLEM(100) Init Ambiguous name for method of
> > Products.User
> > Counter.Counter.UserCounter: "manage" != "manage_main"
> >
> > How can I fix this?
manage=manage_main=manage_navigator
try: # Zope 2.4+
manage_main._setName( 'manage_main' )
except: # lesser zopes dont need this
pass