[Zope] Sendmail, Python and ZPT

Mike Renfro renfro@tntech.edu
Mon, 4 Nov 2002 07:51:28 -0600


On Mon, Nov 04, 2002 at 04:42:10AM -0400, beno wrote:

> I changed the name of the script to mailScript() from
> superValues(). I didn't pass any parameters. The original script had
> *Mail Host* as opposed to *MailHost* but I tried both. What am I
> missing?

The explanation attached to the recipe said "if you have a Mail Host
anywhere below the location of this script (superValues()) it will use
the first one it finds (thus the [0]). if not it will raise an
Exception, which you can catch in your DTML. "

So the superValues() call is pretty essential to its function. I'm not
sure how "above" and "below" were defined for the author, but add a
mailhost object somewhere in one of the parent folders of the script
and try it unedited first.

-- 
Mike Renfro  / R&D Engineer, Center for Manufacturing Research,
931 372-3601 / Tennessee Technological University -- renfro@tntech.edu