[Zope3-checkins] CVS: Zope3/lib/python/Zope/App/DependencyFramework/tests - BaseTestIDependable.py:1.1 __init__.py:1.1 testDependable.py:1.1

Martijn Pieters mj@zope.com
Mon, 14 Oct 2002 10:35:14 -0400


On Mon, Oct 14, 2002 at 07:51:05AM -0400, Jim Fulton wrote:
> class BaseTestIDependable:
          [.......]

>     def testVerifyInterface(self):
          [.......]

>     def test(self):
          [.......]

These are very generic method names for a mixin test class. What if all
Interface test mixins used these method names? I wouldn't be able to
implement a test for an object that implemented multiple interfaces, because
only one test mixin would be visible.

In our current project we make wide use of interface class test mixins and
they all have explicit, verbose test names. A super-generic name like 'test'
would spell disaster here..

-- 
Martijn Pieters
| Software Engineer  mailto:mj@zope.com
| Zope Corporation   http://www.zope.com/
| Creators of Zope   http://www.zope.org/
---------------------------------------------