[Zope3-checkins]
SVN: Zope3/branches/philikon-widget-subdirective/src/zope/app/testing/ztapi.py
deprecate the handle() function;
the name is confusing and the function
Philipp von Weitershausen
philikon at philikon.de
Sat Jun 25 12:35:52 EDT 2005
Log message for revision 30922:
deprecate the handle() function; the name is confusing and the function
isn't too useful with the subscribe() function being in place
Changed:
U Zope3/branches/philikon-widget-subdirective/src/zope/app/testing/ztapi.py
-=-
Modified: Zope3/branches/philikon-widget-subdirective/src/zope/app/testing/ztapi.py
===================================================================
--- Zope3/branches/philikon-widget-subdirective/src/zope/app/testing/ztapi.py 2005-06-25 16:30:17 UTC (rev 30921)
+++ Zope3/branches/philikon-widget-subdirective/src/zope/app/testing/ztapi.py 2005-06-25 16:35:52 UTC (rev 30922)
@@ -78,6 +78,7 @@
gsm = zapi.getGlobalSiteManager()
gsm.subscribe(required, provided, factory)
+# BBB: Deprecated. Gone in 3.3
def handle(required, handler):
subscribe(required, None, handler)
@@ -94,7 +95,7 @@
provideView(None, None, ITraversable, name, handler)
-# BBB: Deprecated. Gone in X3.3.
+# BBB: Deprecated. Gone in 3.3.
from zope.deprecation import deprecated
def provideService(name, service, interface=None):
@@ -105,4 +106,9 @@
deprecated('provideService',
'The concept of services has been removed. Use utilities instead. '
- 'The reference will be gone in X3.3.')
+ 'The reference will be gone in 3.3.')
+
+deprecated('handle',
+ 'The handle(required, handler) function as a shorter spelling of '
+ 'subscribe(required, None, handler) has been deprecated to avoid '
+ 'nomenclature confusion with zope.component.handle.')
More information about the Zope3-Checkins
mailing list