I just posted a mini-proposal for a different spelling for
the schema functions. Comments welcome, especially from
folks who actually know the design decisions behind the
schema package.
http://dev.zope.org/Zope3/SchemaAdapter
I am, naturally, volunteering to implement this if accepted <grin>.
--RDM