JF> - A proposal that makes a distinction between declaration and
JF> query functions. Declaration functions use the word
JF> "implements" and query functions use the word "interfaces".
What about using a specific "get" prefix for the query functions? I
find getInterfaces() clearer than just interfaces().
-Barry