[Zope3-dev] RFC: Local Component Management Simplification
amos at latteier.com
Fri Feb 3 13:30:09 EST 2006
In general I like the proposal, but I have a small nit:
registerSubscriptionAdapter's signature indicates that one of its
arguments is "adapts", but the docstring indicates that it is named
"required". The same thing is true with unregisterSubscriptionAdapter,
registerHandler, and unregisterHandler.
Which is preferred, "adapts" or "required"? Adapts seems more natural to
me since it echoes the name of the adapts() function, but perhaps I'm
missing something that makes "required" more appropriate.
More information about the Zope3-dev