[Zope3-dev] RFC: Local Component Management Simplification

Jim Fulton jim at zope.com
Fri Feb 3 13:33:23 EST 2006

Amos Latteier wrote:
> Hi,
> In general I like the proposal, but I have a small nit:
> registerSubscriptionAdapter's signature indicates that one of its 
> arguments is "adapts", but the docstring indicates that it is named 
> "required". The same thing is true with unregisterSubscriptionAdapter, 
> registerHandler, and unregisterHandler.
> Which is preferred, "adapts" or "required"? Adapts seems more natural to 
> me since it echoes the name of the adapts() function, but perhaps I'm 
> missing something that makes "required" more appropriate.

Oops. Fixed. I don't know where "adapts" came from.



Jim Fulton           mailto:jim at zope.com       Python Powered!
CTO                  (540) 361-1714            http://www.python.org
Zope Corporation     http://www.zope.com       http://www.zope.org

More information about the Zope3-dev mailing list